Announcement

Collapse
No announcement yet.

Corsair micro.......what am I doing wrong?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Corsair micro.......what am I doing wrong?

    I have recently purchased a Corsa Micro fitted with a Corsair Mini Pro Tank. I'm not interested in making big clouds of smoke, I just want a smooth satisfying vape so I have fitted a 1.5 ohm atomizer following the instructions in the little handbook. Applying a few (5) drops of my favourite liquid to the atomiser before fitting, only half filling the tank. I have set the wattage to 8.5 which should be fine with this atomiser but all I get when I press the firing button is a lot of popping and crackling and a mouth full of hot raw liquid and very little vapour. Thinking I might have a dodgy atomiser I replaced it and repeated the same process as per the instruction book...........same result. I've tried lowering the wattage but still no joy. I've now fitted a third atomiser and tried priming it with just 3 drops, 8.5 watts setting and.....guess what? Still loads of popping and crackling and a mouth full of hot liquid. HELP.......what am I doing wrong?

  • #2
    You can try pulsing the coil a few times with the mouthpiece pointed away from your face, or firing off a few bursts while blowing in through the air intake, just to bed the coil in.
    Or, if you have Ni/Ti/SS coils, give temp control a go...

    Most coils pop and crackle a fair bit when new and/or cold. It shouldn't be excessive, though.
    When you say a mouth full, do you mean that, or just a couple of spots?

    Beyond that, it's just what happens whenever one puts cold liquid onto hot metal, such as ejuice onto a fresh, hot coil... nature of the beast.

    Comment


    • #3
      I've just got the corsa micro, there are 2 different types of coils in the pack (0.5 and 1.5). i think one of them you prime with a drop of fluid (0.5) but the other looks a bit different to the instructions. I followed the instructions as you did it spat quite a lot. I think the instructions were for the other type of coil but i might be wrong.

      Comment


      • #4
        The 1.5ohm atomizer head has flooded (become oversaturated with E-liquid), if it happens again, the quickest way to resolve the problem is to hold the Corsa Micro battery firmly in your hand, then simply flick the tanks mouthpiece firmly towards the floor a few times, this will expel any excess E-liquid from the atomizer head. It should vape properly then.

        Comment


        • #5
          Thanks for all of your help and advice. I have the Corsa Micro working perfectly now following the hints and tips you've given. It'll be interesting to see what happens when I need to change the atomiser. I think I'll go a little easier priming it......perhaps just 2 drops of liquid next time.
          ​​​​

          Comment

          Working...
          X